You are browsing the archive for AMF.

sfAmfPlugin 1.5.0 released

11. January 2010 in AMF, Flex, Symfony

Hi all,

I have just released the version 1.5.0 of the sfAmfPlugin.You can get it from here.

The new version brings some fixes and new features. Most noteably:

  • Updated version of SabreAMF inlcuded (latest development version)
  • Symfony 1.3 and 1.4 Support
  • First version of a AMF Service Browser (thanks to Benoît Gouchet)

The plan for the next version shows improvements for Class Mapping, VO and Caching. And I promise to create a better documentation for it…

sfAmfPlugin 1.4.2

5. August 2009 in AMF, doctrine, Flex, General, Symfony

I released a new version of the Symfony-Plugin sfAmfPlugin som hours ago. With the new version the communication between Flex and Symfony is easier than ever.The new version brings big improvements regarding the Doctrine Adapters. Relations between classes are handled better now. The error_reporting is working now as it should and there is a default implementation of a gateway module included.I hope you like it and find it useful. And as always I would like to hear from you if there are bugs or feature requests.Get it while it’s hot :-)Timo

sfAmfPlugin 1.3.0 released

5. May 2009 in AMF, doctrine, Flex, General, Symfony

Just want to inform you that my sfAmfPlugin for Symfony-Flex-Communication was released in version 1.3.0.

Most noticeable changes:

  • Fixing a bug with PHP Strict mode (thanks to Daniel Holmes for spotting this one)
  • Adding the possibility to store the services in all lib-folders of a project (app, module, project, plugins)
  • Fixing different bugs with AMF conversion of Doctrine objects (thanks to Patrick Schirch for bugging me about them)

I’m still working to get the Doctrine support better, there will be much more about this in the next version of the plugin. Class mapping is also a thing I want to improve a lot. So stay tuned and watch out for future versions :-)

sfAmfPlugin 1.2.3 for Flex/Symfony released

16. April 2009 in AMF, Flex, General, Symfony

Hi,

just for your information: I released the version 1.2.3 of the sfAmfPlugin earlier this day. The new version is a pretty important update so please install the new version.

The most important change is the fix of the bug taht caused problems with the usage of packages for the service classes

Installation as always:

$> symfony plugin:install sfAmfPlugin

If you want more information about the plugin vistit the symfony plugin page or read the the HelloWorld example blog post.

Timo